I do what I can

Random thoughts from Mauricio Teixeira…

Democracy Player for SUSE 10.1

with 4 comments

After a lot of work I got Democracy Player to build on SUSE 10.1. The packages are on my personal repository.

Unfortunately I’m having issues while running it, since I get some SEGFAULTs when opening it, and I still couldn’t figure out what’s wrong. I’m quite sure it has something to do with my huge mix of 3rd party repos. If someone could test and report your experiences (in the comments section bellow), it would be much appreciated.

Also, I could not make it work for 10.0, and I won’t even try. After the 5th package I had to backport from 10.1 to 10.0, I just decided it was too risky that I would break someone’s system, and give up. OTOH, I think I’ll have a 10.2 package pretty soon.

Have fun!🙂

Written by netmask

dezembro 8, 2006 às 16:48

Publicado em Uncategorized

Tagged with

4 Respostas

Subscribe to comments with RSS.

  1. Wish to thank you for your work on DemocracyPlayer, unfortunatly though it install it will not run for me

    first:
    /usr/bin/democracyplayer
    Traceback (most recent call last):
    File “/usr/bin/democracyplayer”, line 5, in
    import democracy.xlibhelper as xlibhelper
    ImportError: No module named democracy.xlibhelper

    The problem here seems to be you placed democracy in python2.4 where as I’m runnin 2.5 so I just did a link to resolve this

    Next
    /usr/bin/democracyplayer
    Traceback (most recent call last):
    File “/usr/bin/democracyplayer”, line 5, in
    import democracy.xlibhelper as xlibhelper
    ImportError: /usr/lib64/python2.5/site-packages/democracy/xlibhelper.so: undefined symbol: Py_InitModule4

    running suse 10.2 x64

    regards,

    bill

    dezembro 8, 2006 at 22:50

  2. Sorry I’m an idiot, I configured Smart with the 10.1 repository – please delete and thanks,

    bill

    dezembro 8, 2006 at 23:01

  3. I’m still working on the 10.2 package. Stay tuned.🙂

    netmask

    dezembro 8, 2006 at 23:40

  4. Noticed there’s a new version and tried installing it, it called for Python 2.4 but I changed the call to 2.5 and it installed but I get the following error when running:

    File “/usr/local/bin/democracyplayer”, line 21, in
    import gtcache
    File “/usr/local/lib64/python2.5/site-packages/democracy/gtcache.py”, line 5, in
    import config
    File “/usr/local/lib64/python2.5/site-packages/democracy/config.py”, line 8, in
    import eventloop
    File “/usr/local/lib64/python2.5/site-packages/democracy/eventloop.py”, line 17, in
    import database
    File “database.pyx”, line 13, in database
    ImportError: /usr/lib64/libboost_python.so.1.33.1: undefined symbol: Py_InitModule4

    did you get it? is it a 2.5 thing? how, if you did, did you fix?

    thanks,

    bill

    dezembro 31, 2006 at 13:18


Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: